码迷,mamicode.com
首页 > Web开发 > 详细

Wireless Network

时间:2015-08-26 12:16:21      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


题解:简单并查集。只需要把修好的和距离小于d的加入同一个集合就行了。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int pre[1005];
int X[1005];
int Y[1005]; 
int map[1003][1003];
bool good[1005];

int find(int x)
{
	return x == pre[x] ? x : find(pre[x]);
 } 

int cal(int x1,int y1,int x2,int y2)
{
	return (x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2);
}

int main()
{
	int n,d;
	while(scanf("%d%d",&n,&d) != EOF)
	{
		for(int i = 1;i <= n;i++)
		{
			pre[i] = i;
		} 
		for(int i = 1;i <= n;i++)
		{
			scanf("%d%d",&X[i],&Y[i]);
			for(int j = 1;j < i;j++)
			{
				int t = cal(X[i],Y[i],X[j],Y[j]);
				map[i][j] = map[j][i] = t;
			}
		}
		
		memset(good,false,sizeof(good));
		char s[10];
		int u,v;
		d *= d;
		while(scanf("%s",s) != EOF)
		{
			if(s[0] == '#')
			{
				break;
			}
			if(s[0] == 'O')
			{
				scanf("%d",&u);
				good[u] = true;
				for(int i = 1;i <= n;i++)
				{
					if(map[u][i] <= d && good[i])
					{
						int x = find(i);
						int y = find(u);
						if(x != y)
						{
							pre[y] = x; 
						}
					}
				}
			}
			else
			{
				scanf("%d%d",&u,&v);
				int x = find(u);
				int y = find(v);
				if(x == y)
				{
					printf("SUCCESS\n");
				}
				else
				{
					printf("FAIL\n");
				}
			}
		}
	}
	
	
	return 0;
 } 


版权声明:本文为博主原创文章,未经博主允许不得转载。

Wireless Network

标签:

原文地址:http://blog.csdn.net/wang2534499/article/details/47999527

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!