码迷,mamicode.com
首页 > Web开发 > 详细

POJ - 2236 Wireless Network(简单并查集)

时间:2015-08-26 15:52:48      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:acm   并查集   

Time Limit: 10000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


简单并查集,输入n电脑数量和d两台电脑的最大通信距离,下面n行是1-n台电脑的位置坐标,接下来输入到文件结束是操作O a,表示修好第a台电脑,S a b查询这两台电脑是否可以通信。每次修好一台电脑遍历存在的电脑,把通信范围内的电脑并入一个集合就好了。注意输入到文件结束。


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

struct Point
{
	int x, y;
};

const int MAXN = 1000 + 100;
int parent[MAXN];
int n, d;
Point p[MAXN];
bool isrep[MAXN];

void make_set()
{
	for (int i = 0; i <= n; i++)
	{
		parent[i] = i;
		isrep[i] = false;
	}
}

int find_set(int t)
{
	if (parent[t] == t)
		return t;
	else
		return parent[t] = find_set(parent[t]);
}

void union_set(int a, int b)
{
	int t1 = find_set(a);
	int t2 = find_set(b);
	if (t1 != t2)
	{
		parent[t2] = t1;
	}
}

bool isIn(Point a, Point b)
{
	int dd = (a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y);
	if (dd <= d*d) return true;
	return false;
}

int main()
{
	scanf("%d%d", &n, &d);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d%d", &p[i].x, &p[i].y);
	}

	char op;
	int a, b;

	make_set();

	while(cin>>op)
	{
		if (op == 'S')
		{
			scanf("%d%d", &a, &b);
			if (find_set(parent[a]) == find_set(parent[b]))
				printf("SUCCESS\n");
			else
				printf("FAIL\n");
		}
		else
		{
			scanf("%d", &a);
			for (int j = 1; j <= n; j++)
			{
				if (isrep[j])
				{
					if (isIn(p[a], p[j]))
						union_set(a, j);
				}
			}
			isrep[a] = true;
		}
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ - 2236 Wireless Network(简单并查集)

标签:acm   并查集   

原文地址:http://blog.csdn.net/qq_18738333/article/details/48003345

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!