码迷,mamicode.com
首页 > Web开发 > 详细

poj 1459 Power Network

时间:2015-08-31 16:40:12      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://poj.org/problem?id=1459  

Power Network

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

技术分享


An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Dinic求最大流。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::min;
using std::find;
using std::sort;
using std::pair;
using std::queue;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 210;
const int INF = 0x3f3f3f3f;
struct Dinic {
    struct edge { int to, cap, next, rev; }G[(N * N) << 1];
    int s, t, tot, level[N], ite[N], head[N];
    inline void init() {
        tot = 0, cls(head, -1);
    }
    inline void add_edge(int u, int v, int cap) {
        G[tot] = (edge){ v, cap, head[u], tot + 1 }; head[u] = tot++;
        G[tot] = (edge){ u,   0, head[v], tot - 1 }; head[v] = tot++;
    }
    inline void built(int n, int np, int nc, int m) {
        int u, v, f;
        s = 0, t = n + 1;
        rep(i, m) {
            scanf(" (%d,%d)%d", &u, &v, &f);
            add_edge(u + 1, v + 1, f);
        }
        rep(i, np) {
            scanf(" (%d)%d", &v, &f);
            add_edge(s, v + 1, f);
        }
        rep(i, nc) {
            scanf(" (%d)%d", &u, &f);
            add_edge(u + 1, t, f);
        }
    }
    inline void bfs(int s) {
        cls(level, -1);
        queue<int> q;
        q.push(s);
        level[s] = 0;
        while(!q.empty()) {
            int u = q.front(); q.pop();
            for(int i = head[u]; ~i; i = G[i].next) {
                edge &e = G[i];
                if(e.cap > 0 && level[e.to] < 0) {
                    level[e.to] = level[u] + 1;
                    q.push(e.to);
                }
            }
        }
    }
    inline int dfs(int u, int t, int f) {
        if(u == t) return f;
        for(int &i = ite[u]; ~i; i = G[i].next) {
            edge &e = G[i];
            if(e.cap > 0 && level[u] < level[e.to]) {
                int d = dfs(e.to, t, min(e.cap, f));
                if(d > 0) {
                    e.cap -= d;
                    G[e.rev].cap += d;
                    return d;
                }
            }
        }
        return 0;
    }
    inline int max_flow() {
        int flow = 0;
        while(true) {
            bfs(s);
            if(level[t] < 0) break;
            int f;
            rep(i, t) ite[i] = head[i];
            while((f = dfs(s, t, INF)) > 0) {
                flow += f;
            }
        }
        return flow;
    }
    inline void solve(int n, int np, int nc, int m) {
        init(), built(n, np, nc, m);
        printf("%d\n", max_flow());
    }
}go;
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int n, np, nc, m;
    while(~scanf("%d %d %d %d", &n, &np, &nc, &m)) {
        go.solve(n, np, nc, m);
    }
    return 0;
}

poj 1459 Power Network

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4773082.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!