码迷,mamicode.com
首页 > Web开发 > 详细

HDU1045 Fire Net(DFS)

时间:2015-09-01 01:42:52      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8185    Accepted Submission(s): 4691

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
技术分享
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.
 
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 
Sample Input
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
 
 
Sample Output
5
1
5
2
4
题意: 有图n*n一张, 图里有地方有“墙”, 然后往里面放子弹, 子弹不能和子弹同列或同行(除非被墙隔开啦!), 问:最多能放多少子弹?
技术分享
/*
本题思路: 暴力DFS, 每个点都先假设放上子弹,
然后判断是否成立再DFS。不过在分别判断行和列是否合法
时, 是从小到大DFS的, 所以只判断前面的即可! 
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char pic[10][10];
int ans, n;
int Judge(int row, int col)
{
    for(int i=col-1; i>=0; i--)//判断所在列 
    {
        if(pic[row][i]==a) return false;
        if(pic[row][i]==X) break;
    }
    for(int i=row-1; i>=0; i--)//判断所在行 
    {
        if(pic[i][col]==a) return false;
        if(pic[i][col]==X) break;
    }
    return true;
}
void dfs(int cur, int tot)
{
    if(cur==n*n)
    {
        ans = max(ans, tot);
        return;
    }
    else
    {
        int row = cur/n;//这里是一个很有意思的小技巧 
        int col = cur%n;
        if(pic[row][col]==.&&Judge(row, col))
        {
            pic[row][col]=a;
            dfs(cur+1, tot+1);
            pic[row][col] = .;
        }
        dfs(cur+1, tot);
    }
}

int main()
{
    while(scanf("%d", &n), n)
    {
        memset(pic, 0, sizeof(pic));
        for(int i=0; i<n; i++)
        scanf("%s", pic[i]);
        ans = 0;
        dfs(0, 0);
        printf("%d\n", ans);
    }
    return 0;
}
View Code

 然而上述代码有一个缺陷,前面的行和列坑能合理。但是可能放置子弹后(后面也有子弹且无墙),导致不合理。 然而这道题的数据奇弱,因此能过。

下述代码虽然比上面的跑的稍慢,但仍是0ms飘过。(这道题的数据规模真是亲民)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char pic[10][10];
int ans, n;
int Judge(int row, int col)
{
    for(int i=n-1; i>=0; i--)//判断所在列 
    {
        if(pic[row][i]==a) return false;
        if(pic[row][i]==X) break;
    }
    for(int i=n-1; i>=0; i--)//判断所在行 
    {
        if(pic[i][col]==a) return false;
        if(pic[i][col]==X) break;
    }
    return true;
}
void dfs(int cur, int tot)
{
    if(cur==n*n)
    {
        ans = max(ans, tot);
        return;
    }
    else
    {
        int row = cur/n;//这里是一个很有意思的小技巧 
        int col = cur%n;
        if(pic[row][col]==.&&Judge(row, col))
        {
            pic[row][col]=a;
            dfs(cur+1, tot+1);
            pic[row][col] = .;
        }
        dfs(cur+1, tot);
    }
}

int main()
{
    while(scanf("%d", &n), n)
    {
        memset(pic, 0, sizeof(pic));
        for(int i=0; i<n; i++)
        scanf("%s", pic[i]);
        ans = 0;
        dfs(0, 0);
        printf("%d\n", ans);
    }
    return 0;
}

 

 

HDU1045 Fire Net(DFS)

标签:

原文地址:http://www.cnblogs.com/acm1314/p/4774436.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!