码迷,mamicode.com
首页 > 系统相关 > 详细

PKU 1276 Cash Machine

时间:2015-09-08 12:21:42      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

<span style="color:#000099;">/*
Cash Machine
Time Limit: 1000MS  Memory Limit: 10000K 
Total Submissions: 26604  Accepted: 9397 

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output

735
630
0
0
Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
Source

Southeastern Europe 2002
pku 1276
By ivi
2014.7.1
多重背包
这道题从一開始的转化为01背包的超时,到后来的数组开小的执行时错误,再到超内存、、超时、、,
到最后深夜1:40的AC,过程真辛苦
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int f[13];
int p[13];
bool dp[111113];
int num=0;
int n=0;
 
int main()
{int temp,i;
   while(scanf("%d%d",&num,&n)!=EOF){

        for(i=1;i<=n;i++)
         scanf("%d%d",&f[i],&p[i]);
        if(num==0)
            cout<<"0"<<endl;
        else if(n==0)
             cout<<"0"<<endl;
        else {
            memset(dp,0,num+3);
    m=0;
    dp[0]=1;
    for(int k=1;k<=n;k++)
            
          for(int j=m;j>=0;j--)
              if(dp[j]){
                 for(int i=1;i<=f[k];i++)
                   {
                       temp=i*p[k]+j;
                        if(temp<=num)
                        {
                          dp[temp]=1;
                            if(temp>m)
                              m=temp;
                              }
                   }
                   }
        cout<<m<<endl;}

         }
   return 0;
}
</span>

版权声明:本文博主原创文章。博客,未经同意不得转载。

PKU 1276 Cash Machine

标签:

原文地址:http://www.cnblogs.com/mengfanrong/p/4791164.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!