码迷,mamicode.com
首页 > 编程语言 > 详细

【电话号码排序--简单 qsort函数】

时间:2015-09-26 13:15:34      阅读:269      评论:0      收藏:0      [点我收藏+]

标签:

                                                     Phone List

                           Time Limit: 2 Sec  Memory Limit: 64 MB Submit: 359  Solved: 79 [Submit][Status][Discuss]

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let‘s say the phone catalogue listed these numbers:

- Emergency 911
- Alice 97 625 999
- Bob 91 12 54 26

In this case, it‘s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob‘s phone number. So this list would not be consistent.

 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000.Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

 

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

 

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

HINT

zoj2876

 

Source

The 2007 Nordic Collegiate Programming Contest

 

   注释:qsort函数格式:  int cmp(const void* a,const void* b)
                                   {
                                              return strcmp((char*)a,(char*)b);
                                   }
                                    int main()

                                   {  

                                              qsort(a,n,sizeof(a[0])【数组内存大小】,cmp);【大小排序】

                                   }

 

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int cmp(const void* a,const void* b)
{
    return strcmp((char*)a,(char*)b);
}
int main()
{
    int t,n,i,temp,j,len;
    char a[10000][20],str[20];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);getchar();
        temp=0;
        for(i=0;i<n;i++)
        {
            gets(a[i]);
        }

        qsort(a,n,sizeof(a[0]),cmp);

        for(i=0;i<n-1;i++)
        {
            if(strncmp(a[i],a[i+1],strlen(a[i]))==0)
            {
                temp=1;
                break;
            }
        }
        if(temp==0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;

}

  

  

【电话号码排序--简单 qsort函数】

标签:

原文地址:http://www.cnblogs.com/zhangfengnick/p/4840633.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!