码迷,mamicode.com
首页 > Web开发 > 详细

poj 1144 Network【双连通分量求割点总数】

时间:2015-10-18 23:07:08      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:

Network
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11042   Accepted: 5100

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it‘s easy to determine,there are no extra blank before the end of each line.
 
题意:一个数n接下来最多n行(可以少于n行)每行第一个数a  接下来是随机n-1个数b,a和b之间相连  求最后组成的图中割点总数
 
我的输入方法真的不知道错那了   输入略坑
#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
#define MAX 1100
#define MAXM 2000100
#define INF 0x7fffff
using namespace std;
struct node
{
	int beg,end,next;
}edge[MAXM];
int low[MAX],dfn[MAX];
int head[MAX],ans;
int dfsclock;
int iscut[MAX];
void init()
{
	ans=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
	edge[ans].beg=u;
	edge[ans].end=v;
	edge[ans].next=head[u];
	head[u]=ans++;
}
void tarjan(int u,int fa)
{
	int v,i;
	low[u]=dfn[u]=++dfsclock;
	int son=0;
	for(i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].end;
		if(!dfn[v])
		{
			son++;
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
			if(u!=fa&&dfn[u]<=low[v])
				iscut[u]=1;
		}
		else
		    low[u]=min(dfn[v],low[u]);
	}
	if(fa==u&&son>1)
        iscut[u]=1;
}
void find(int l,int r)
{
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(iscut,0,sizeof(iscut));
	dfsclock=0;
	for(int i=l;i<=r;i++)
	{
		if(!dfn[i])
		   tarjan(i,i);
	}
}
int main()
{
	int n,m,j,i,t;
	int a,c,len;
	char b;
	char s[5010];
	while(scanf("%d",&n),n)
	{
		init();
		int sum=0;
		
		while(scanf("%d", &a), a)
		{
	       while(getchar() != ‘\n‘)
		   {  
	           scanf("%d", &c);  
	           add(a,c); 
			   add(c,a);
	       }  
        }  
        
        
//		while(scanf("%d",&a),a)  我真的搞不懂我这个输入错在哪里一直wa 
//		{
//			while(scanf("%c",&b)&&b!=‘\n‘)
//			{
//				c=b-‘0‘;
//				add(a,c);
//				add(c,a);
//			}
//		}	

	
		find(1,n);
		for(i=1;i<=n;i++)
		{
			if(iscut[i])
			    sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
} 

  

poj 1144 Network【双连通分量求割点总数】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4890572.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!