码迷,mamicode.com
首页 > Web开发 > 详细

POJ1258 Agri-Net

时间:2015-10-23 21:34:31      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 46319   Accepted: 19052

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

 
prim求最小生成树
prim和dijkstra的代码只有更新dis数组这一块是不同的,prim中dis[i]表示的是i到当前生成树的距离,dijkstra中dis[i]表示的是i到源点s的距离
/*
ID: LinKArftc
PROG: 1258.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 110;

int mp[maxn][maxn];
int dis[maxn];
bool vis[maxn];
int n;

int prim() {
    int ret = 0;
    for (int i = 2; i <= n; i ++) dis[i] = mp[i][1];
    dis[1] = 0;
    vis[1] = true;
    int ii = 1;
    for (int i = 2; i <= n; i ++) {
        int mi = inf;
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && dis[j] < mi) {
                mi = dis[j];
                ii = j;
            }
        }
        vis[ii] = true;
        ret += dis[ii];
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && dis[j] > mp[j][ii]) dis[j] = mp[j][ii];
        }
    }
    return ret;
}

int main() {

    //input;
    while (~scanf("%d", &n)) {
        memset(mp, 0x3f, sizeof(mp));
        memset(vis, 0, sizeof(vis));
        for (int i = 1; i <= n; i ++) {
            for (int j = 1; j <= n; j ++) scanf("%d", &mp[i][j]);
        }
        printf("%d\n", prim());
    }

    return 0;
}

 

POJ1258 Agri-Net

标签:

原文地址:http://www.cnblogs.com/LinKArftc/p/4905681.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!