码迷,mamicode.com
首页 > 移动开发 > 详细

Proving Equivalences(加多少边使其强联通)

时间:2015-10-28 22:58:04      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4384    Accepted Submission(s): 1556


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

 

Sample Input
2 4 0 3 2 1 2 1 3
 

 

Sample Output
4 2
 代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<stack>
#include<vector>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
const int MAXN=20010;
int scc,dfs_blocks;
int dfn[MAXN],low[MAXN],Instack[MAXN],in[MAXN],out[MAXN],sc[MAXN];
stack<int>S;
vector<int>vec[MAXN];
void initial(){
    scc=0;dfs_blocks=0;
    mem(dfn,0);mem(low,0);mem(Instack,0);mem(in,0);mem(out,0);mem(sc,0);
    while(!S.empty())S.pop();
    for(int i=0;i<MAXN;i++)vec[i].clear();
}
void targin(int u,int fa){
    S.push(u);
    Instack[u]=1;
    dfn[u]=low[u]=++dfs_blocks;
    for(int i=0;i<vec[u].size();i++){
        int v=vec[u][i];
        if(!dfn[v]){
            targin(v,u);
            low[u]=min(low[u],low[v]);
        }
        else if(Instack[v]){
            low[u]=min(low[u],dfn[v]);
        }
    }
    if(low[u]==dfn[u]){
        scc++;
        while(1){
            int v=S.top();
            S.pop();
            Instack[v]=0;
            sc[v]=scc;
            if(u==v)break;
        }
    }
}
int main(){
    int T,m,n,x,y;
    scanf("%d",&T);
    while(T--){
        initial();
        scanf("%d%d",&n,&m);
        while(m--){
            scanf("%d%d",&x,&y);
            vec[x].push_back(y);
        }
        for(int i=1;i<=n;i++){
            if(!dfn[i])targin(i,-1);
        }
        for(int i=1;i<=n;i++){
            for(int j=0;j<vec[i].size();j++){
                int v=vec[i][j];
                if(sc[i]!=sc[v])in[sc[v]]++,out[sc[i]]++;
            }
        }
        int sumin=0,summa=0;
    //    printf("%d\n",scc);
    if(scc==1){
        puts("0");continue;
    }
        for(int i=1;i<=scc;i++){
            if(in[i]==0)sumin++;
            if(out[i]==0)summa++;
            
        }
        printf("%d\n",max(sumin,summa));
    }
    return 0;
}

 

Proving Equivalences(加多少边使其强联通)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/4918879.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!