码迷,mamicode.com
首页 > Web开发 > 详细

POJ 1287:Networking(最小生成树Kruskal)

时间:2014-07-19 23:35:59      阅读:300      评论:0      收藏:0      [点我收藏+]

标签:kruskal   networking   poj   



Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5976   Accepted: 3231

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

题意:

P个点,R对边,找出最小通路和

分析:

长度为边权的最小生成树问题


kruskal & 并查集



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue>
#define INF 0x3f3f3f3f

using namespace std;

const int maxn=5100;

int r[maxn];
int n, m;

struct node
{
    int x;
    int y;
    int cost;
};
node a[maxn];

bool cmp ( node a, node b )
{
    return a.cost<b.cost;
}

void init()
{
    for( int i=0; i<n; i++ )
        scanf( "%d%d%d", &a[i].x, &a[i].y, &a[i].cost );
    sort( a, a+n, cmp );
    for( int i=0; i<n; i++ )
        r[i] = i;
}

int find( int x )
{
    return r[x]==x? x : r[x] = find( r[x] );
}

void kruskal()
{
    int cnt = 0;
    int ans = 0;
    int x; int y;
    for( int i=0; i<n; i++ )
    {
        x = find( a[i].x );
        y = find( a[i].y );
        if( x!=y )
        {
            cnt++;
            ans += a[i].cost;
            if( cnt == m-1 )
                break;
            r[y] = x;
        }
    }
    printf( "%d\n", ans );
}

int main()
{
    while( scanf( "%d", &m )==1 &&m )
    {
        scanf( "%d", &n );
        init();
        kruskal();
    }
    return 0;
}






POJ 1287:Networking(最小生成树Kruskal)

标签:kruskal   networking   poj   

原文地址:http://blog.csdn.net/u013487051/article/details/37968379

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!