码迷,mamicode.com
首页 > 移动开发 > 详细

django 运行python manage.py sqlall books 时报错 app has migration

时间:2015-11-23 23:39:46      阅读:442      评论:0      收藏:0      [点我收藏+]

标签:

  出现这个问题的原因是版本之前的不兼容,我用的django版本是1.8.6 而 这条python manage.py sqlall books 是基于django1.0版本的。

    在django1.8.6版本中生成一个表的语句是    $ python manage.py makemigrations books

                       $ python manage.py sqlmigrate books 0001

django book2 是一本不错的教程,但是就是版本太老了,可以通过看book2对django有一个比较清晰的认识,但是如果编写程序的话还是要看相应版本的英文文档

 

django 运行python manage.py sqlall books 时报错 app has migration

标签:

原文地址:http://www.cnblogs.com/xiaoli2018/p/4990002.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!