码迷,mamicode.com
首页 > 编程语言 > 详细

Ultra-QuickSort(归并排序+离散化树状数组)

时间:2015-11-28 09:06:46      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 50517   Accepted: 18534

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
题解:归并排序注意对dt主数组的更改,由于数据太大999999999所以要离散化
归并:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
typedef long long LL;
#define mem(x,y) memset(x,y,sizeof(x))
#define T_T while(T--)
#define F(i,x) for(i=1;i<=x;i++)
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
#define PI(x) printf("%d",x)
#define PL(x) printf("%lld",x)
#define P_ printf(" ")
const int MAXN=500010;
int dt[MAXN],b[MAXN];
LL ans;
void mergesort(int l,int mid,int r){
	int ll=l,rr=mid+1,pos=l;
	while(ll<=mid&&rr<=r){
		if(dt[ll]<=dt[rr])b[pos++]=dt[ll++];
		else{
			ans+=rr-pos;
			b[pos++]=dt[rr++];
		}
	}
	for(int i=ll;i<=mid;i++)b[pos++]=dt[i];
	for(int i=rr;i<=r;i++)b[pos++]=dt[i];
	for(int i=l;i<=r;i++)dt[i]=b[i];
}
void ms(int l,int r){
	if(l<r){
		int mid=(l+r)>>1;
		ms(l,mid);
		ms(mid+1,r);
		mergesort(l,mid,r);
	}
}
int main(){
	int N;
	while(~scanf("%d",&N),N){
		int i,j;
		ans=0;
		F(i,N)
			SI(dt[i]);
			ms(1,N);
		PL(ans);puts("");
	}
	return 0;
}

  

Ultra-QuickSort(归并排序+离散化树状数组)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5002137.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!