码迷,mamicode.com
首页 > 编程语言 > 详细

1029. Median (25)【排序】——PAT (Advanced Level) Practise

时间:2015-12-03 14:14:58      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

题目信息

1029. Median (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

解题思路

排序

AC代码

#include <cstdio>
#include <algorithm>
using namespace std;
vector<long long> v;
int main()
{
    long long n, t;
    scanf("%lld", &n);
    while (n--){
        scanf("%lld", &t);
        v.push_back(t);
    }
    scanf("%lld", &n);
    while (n--){
        scanf("%lld", &t);
        v.push_back(t);
    }
    nth_element(v.begin(), v.begin() + (v.size() - 1)/2, v.end());
    printf("%lld\n", v[(v.size() - 1)/2]);
    return 0;

}

1029. Median (25)【排序】——PAT (Advanced Level) Practise

标签:

原文地址:http://blog.csdn.net/xianyun2009/article/details/50153561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!