码迷,mamicode.com
首页 > Windows程序 > 详细

POJ 2823 Sliding Window(单调队列)

时间:2014-07-22 00:06:36      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   

看了大神们的博客,仿着写的,地址:点击进入

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

额,单调队列的基础题吧,看了半天,想了半天,对于我这个没有学过数据结构的人来说有点难写。
从队头到队尾,元素在我们所关注的指标下是递减的(严格递减,而不是非递增),比如查询如果每次问的是窗口内的最小值,那么队列中元素从左至右就应该递增,如果每次问的是窗口内的最大值,则应该递减,依此类推。这是为了保证每次查询只需要取队头元素。
#include <iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=1000001;
int Q[maxn];
int P[maxn];
int a[maxn];
int n,k;

void minQ()
{
    int i;
    int head=1,tail=0;
    for(i=0; i<k-1; i++)//先入队
    {
        while(head<=tail && Q[tail]>=a[i])
            --tail;
        Q[++tail]=a[i];
        P[tail]=i;
    }

    for(; i<n; i++)//for执行时每次都要输出一个答案=-=
    {
        while(head<=tail && Q[tail]>=a[i])
            --tail;
        Q[++tail]=a[i];
        P[tail]=i;
        while(P[head]<i-k+1)//移动到合法位置
            head++;
        printf(i==n-1?"%d\n":"%d ",Q[head]);
    }
}
void maxQ()
{
    int i;
    int head=1,tail=0;
    for(i=0;i<k-1;i++)
    {
        while(head<=tail&&Q[tail]<=a[i])
            --tail;
        Q[++tail]=a[i];
        P[tail]=i;
    }
    for(;i<n;i++)
    {
        while(head<=tail&&Q[tail]<=a[i])
            --tail;
        Q[++tail]=a[i];
        P[tail]=i;
        while(P[head]<i-k+1)
            head++;
        printf(i==n-1?"%d\n":"%d ",Q[head]);
    }
}

int main()
{
    while(scanf("%d%d",&n,&k)==2)
    {
       for(int i=0;i<n;i++)
           scanf("%d",&a[i]);
       minQ();
       maxQ();
    }
    return 0;
}


POJ 2823 Sliding Window(单调队列),布布扣,bubuko.com

POJ 2823 Sliding Window(单调队列)

标签:des   style   blog   http   color   os   

原文地址:http://blog.csdn.net/u013582254/article/details/38017561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!