码迷,mamicode.com
首页 > 移动开发 > 详细

迷宫城堡 -- 强联通分量

时间:2015-12-16 22:52:50      阅读:257      评论:0      收藏:0      [点我收藏+]

标签:

迷宫城堡

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10908    Accepted Submission(s): 4887


Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
 

 

Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
 

 

Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
 

 

Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
 

 

Sample Output
Yes No
 

 

Author
Gardon
 

 

Source
 

 

Recommend
lxj   |   We have carefully selected several similar problems for you:  1233 1116 1150 1301 1272 
 
 
强联通算法的模板题-测试一下模板
 
一遍DFS标记出来回溯的顺序(left_time数组)
然后根据回溯的先后顺序从最先发生回溯的那个点开始进行DFS,测试当前的联通情况
 
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<stack>
#include<set>
#include<iostream>
#include<vector>
#include<queue>
//ios_base::sync_with_stdio(false);
//#pragma comment(linker, "/STACK:1024000000,1024000000")

using namespace std;
#define rep(i, a, b) for (int i = (a); i < (b); ++i)
#define repf(i, a, b) for (int i = (a); i <= (b); ++i)
#define repd(i, a, b) for (int i = (a); i >= (b); --i)
#define clr(x) memset(x,0,sizeof(x))
#define sqr(x) ((x) * (x))
typedef long long LL;

const int INF = 1000000000;
const double eps = 1e-8;
const int maxn = 10000 + 10;
const int mod = 1000000000 + 7;
int vis[maxn];
int left_time[maxn];
int n,m;
vector<int> g[maxn];
int max_time;
void dfs(int n){
    if(vis[n]) return;
    vis[n] = 1;
    rep(i,0,g[n].size()){
        if(vis[g[n][i]] == 0){
            dfs(g[n][i]);
        }
    }
    left_time[++max_time] = n;
    return ;
}
void dfs_ans(int n){
    if(vis[n]) return ;
    vis[n] = 1;
    rep(i,0,g[n].size()){
        if(!vis[g[n][i]]){
            dfs_ans(g[n][i]);
        }
    }
    return ;
}
int ans(){
    int ret = 0;
    clr(vis);
    repf(i,1,max_time){
        if(vis[left_time[i]] == 0){
            ret++;
            if(ret > 1) return 1;
            dfs_ans(left_time[i]);
        }
    } 
    return 0;
}
int main() 
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m) == 2){
        if(n == 0 && m == 0) break;
        max_time = 0;
        clr(vis);
        clr(left_time);
        repf(i,1,n) g[i].clear();
        rep(i,0,m){
            int a,b;
            scanf("%d%d",&a,&b);
            g[a].push_back(b);
        }
        dfs(1);
        int flag = 0;
        repf(i,1,n) if(vis[i] == 0) flag = 1;
        if(flag ||  ans()) printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}

 

 

迷宫城堡 -- 强联通分量

标签:

原文地址:http://www.cnblogs.com/NothingElsePKU/p/5052497.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!