码迷,mamicode.com
首页 > 编程语言 > 详细

POJ3067(树状数组:统计数字出现个数)

时间:2016-01-18 22:34:09      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24151   Accepted: 6535

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
题意:两列数字连线,统计线段交叉的产生的点数(交于同一个数字的不算)
#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=1000005;
struct Node{
    int west,east;
}hways[MAXN];
bool comp(const Node &a,const Node &b)
{
    if(a.east != b.east)    return a.east > b.east;
    else return a.west > b.west;
}

int bit[MAXN];
void add(int i,int x)
{
    while(i<MAXN)
    {
        bit[i]+=x;
        i+=i&(-i);
    }
}

long long sum(int i)
{
    long long s=0;
    while(i>0)
    {
        s+=bit[i];
        i-=i&(-i);
    }
    return s;
}

int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        memset(bit,0,sizeof(bit));
        long long ans=0;
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
        {
            scanf("%d%d",&hways[i].east,&hways[i].west);
        }
        sort(hways,hways+k,comp);
        add(hways[0].west,1);
        for(int i=1;i<k;i++)
        {
            ans+=sum(hways[i].west-1);
            add(hways[i].west,1);
        }
        
        
        printf("Test case %d: %I64d\n",cas,ans);
    }
    
    return 0;
}

 

POJ3067(树状数组:统计数字出现个数)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5140529.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!