码迷,mamicode.com
首页 > 编程语言 > 详细

POJ1195(二维树状数组)

时间:2016-01-19 00:04:36      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:

Mobile phones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 17176   Accepted: 7920

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 
技术分享

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4
二维树状数组模板题。
#include"cstdio"
#include"cstring"
using namespace std;
const int MAXN=1024+5;
int bit[MAXN][MAXN];
int lowbit(int i)
{
    return i&(-i);
}
void add(int x,int y,int a)
{
    for(int i=x;i<MAXN;i+=lowbit(i))
        for(int j=y;j<MAXN;j+=lowbit(j))
            bit[i][j]+=a;
}
long long sum(int x,int y)
{
    long long s=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            s+=bit[i][j];
    return s;
}
long long getSum(int x1,int y1,int x2,int y2)
{
    return sum(x2,y2)+sum(x1-1,y1-1)-sum(x2,y1-1)-sum(x1-1,y2);
}
int main()
{
    int Init;
    while(scanf("%d",&Init)!=EOF)
    {
        int n;
        if(Init==0)
        {
            scanf("%d",&n);
            memset(bit,0,sizeof(bit));
        }
        else if(Init==1)
        {
            int x,y,a;
            scanf("%d%d%d",&x,&y,&a);
            x++,y++;
            add(x,y,a);
        }
        else if(Init==2)
        {
            int L,B,R,T;
            scanf("%d%d%d%d",&L,&B,&R,&T);
            L++,B++,R++,T++;
            printf("%I64d\n",getSum(L,B,R,T));
        }
        else
        {
            break;
        }
    }
    
    return 0;
}

 

POJ1195(二维树状数组)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5140683.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!