码迷,mamicode.com
首页 > Windows程序 > 详细

HDU 1509 Windows Message Queue

时间:2016-02-09 21:05:48      阅读:328      评论:0      收藏:0      [点我收藏+]

标签:

题目链接

Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

 

Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.
 
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

 题解:优先队列,写的时候运算符重载一直出问题,还是不懂。而且刚开始没有加idx这个成员,就一直WA,看了看题目也没发现什么诡异的地方,最后看了几个题解,加上了idx就AC了,也不知道是为什么。

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
#define PI acos(-1.0)
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
using namespace std;
//#define LOCAL
struct task
{
    char name[50];
    int value,pri,idx;
    friend bool operator < (task a,task b)
    {
        if(a.pri==b.pri)
        {
            return b.idx<a.idx;
        }
        return b.pri<a.pri;
    }
} t;
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    ios::sync_with_stdio(false);
    priority_queue<task> q;
    //while(!q.empty())q.pop();
    char com[5];
    int k=0;
    while(cin>>com)
    {
        if(com[0]==G)
        {
            if(q.empty())printf("EMPTY QUEUE!\n");
            else printf("%s %d\n",q.top().name,q.top().value),q.pop();
        }
        else
        {
            cin>>t.name>>t.value>>t.pri;
            t.idx=++k;
            q.push(t);
        }
    }
    return 0;
}

 

HDU 1509 Windows Message Queue

标签:

原文地址:http://www.cnblogs.com/gpsx/p/5185682.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!