码迷,mamicode.com
首页 > 编程语言 > 详细

树状数组

时间:2016-03-16 22:13:25      阅读:270      评论:0      收藏:0      [点我收藏+]

标签:

题目网址: http://acm.hust.edu.cn/vjudge/contest/view.action?cid=109331#problem/B

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
 
题意:给出一些星星的横坐标和纵坐标,而且星星的纵坐标按非递减排列,如果纵坐标相等,则横坐标按递增排列,任意两颗星星不会重合。如果有n颗星星的横坐标比某颗星星小而且纵坐标不大于那颗星星(即有n颗星星位于那颗星星的左下角或者左边)则此星星的等级为n,最后输出等级为0至n-1的星星的数量。
 
分析:题目给的数据按照y排序,相同的y按照x排序,我们可以按照由下至上、由左至右的顺序来处理数据,这样我们只利用x就可以进行计数了。当我们处理到任意点p的时候,只需要统计所有x不超过p的点的数量就可以了。由于星星的坐标是按y的递增给出的,那么就只需考虑水平方向,如果给出一个星星的坐标为(x,y),那么它的等级就等于前面已经输入的x坐标在[0,x]区间的星星数量,利用树状数组就可以实现了。
 
树状数组介绍:如下图所示
 
技术分享
 
 
代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define N 32005
using namespace std;
int c[N], level[N];

int Lowbit(int t)
{   ///设k为t末尾0的个数,则求得为2^k=t&(t^(t-1));
    return t&(t^(t-1));
}
int Sum(int x)
{   ///统计求前面所有横坐标小于x的星星的个数;
    int sum = 0;
    while(x > 0)
    {
        sum += c[x];
        x -= Lowbit(x);
    }
    return sum;
}
void add(int li)
{   ///从c[li]往跟节点一路回溯,调整这条路上的所有c[]值;
    while(li<=N)
    {
        c[li]++;
        li=li+Lowbit(li);
    }
}

int main()
{
    int x, y, n;
    scanf("%d", &n);
    memset(c, 0, sizeof(c));
    memset(level, 0, sizeof(level));
    for(int i=1; i<=n; i++)
    {
        scanf("%d%d", &x, &y); ///由于坐标x可能为0,因此输入坐标要+1;
        add(x+1);
        level[Sum(x+1)-1]++;///统计level相同的个数;
    }
    for(int i=0; i<n; i++)
    printf("%d\n", level[i]);
}
 

树状数组

标签:

原文地址:http://www.cnblogs.com/chen9510/p/5285291.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!