码迷,mamicode.com
首页 > 编程语言 > 详细

算法训练 9-7链表数据求和操作

时间:2016-04-01 20:13:19      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:

 算法训练 9-7链表数据求和操作  
时间限制:1.0s   内存限制:512.0MB
    
  读入10个复数,建立对应链表,然后求所有复数的和。
样例输入
1 2
1 3
4 5
2 3
3 1
2 1
4 2
2 2
3 3
1 1
样例输出
23+23i
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        int n=0;int m=0;
        for(int i=0;i<10;i++){
            n+=sc.nextInt();
            m+=sc.nextInt();
        }
        System.out.println(n+"+"+m+"i");
        
    }

}

 

算法训练 9-7链表数据求和操作

标签:

原文地址:http://www.cnblogs.com/watchfree/p/5345798.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!