码迷,mamicode.com
首页 > 编程语言 > 详细

算法训练 最长字符串

时间:2016-04-03 22:07:38      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:

算法训练 最长字符串  
时间限制:1.0s   内存限制:512.0MB
    
  求出5个字符串中最长的字符串。每个字符串长度在100以内,且全为小写字母。
样例输入
one two three four five
样例输出
three
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        String str=sc.nextLine();
        String s[]=str.split(" ");
        int len=s[0].length(); 
        int p=0;
        for(int i=1;i<s.length;i++){
            if(len<s[i].length()){ 
                len=s[i].length();
                p=i;
            }
        }
        System.out.println(s[p]);

    }

}

 

算法训练 最长字符串

标签:

原文地址:http://www.cnblogs.com/watchfree/p/5350662.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!