码迷,mamicode.com
首页 > 移动开发 > 详细

Whu 1604——Play Apple——————【博弈】

时间:2016-04-11 22:33:25      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:

Problem 1604 - Play Apple
Time Limit: 1000MS   Memory Limit: 65536KB   
Total Submit: 442  Accepted: 177  Special Judge: No
Description

There are N apples. Two people take turns to either: 
1. Divide the apple into two piles with different numbers.
2. The other people selects a pile of apples as the beginning of the next turn.
If someone can not meet the requirements, he is lost. Will the first one win the game if both use the best strategy?

Input
There are multiple test cases.
The first line of each case contains a integer N. ( 1 <= N <= 1000000000 )
Output
If the first person will win, output “Yes”. Otherwise, output “No”.
Sample Input
2
3
4
Sample Output
No
Yes
No
 
题目大意:两个人分苹果。两种操作:(1)第一个人把苹果分成不相等的两堆 (2)第二个人挑一堆留下,下轮继续玩。 当某个人不能操作的时候,他就输了。 问你如果两个人都采用最优策略,第一个人是否会赢。
 
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long LL;
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n == 1 || n == 2){
            puts("No");
        }else if(n == 3){
            puts("Yes");
        }else{
            if((n-3) % 3 == 1){
                puts("No");
            }else{
                puts("Yes");
            }
        }
    }
    return 0;
}

  

 

Whu 1604——Play Apple——————【博弈】

标签:

原文地址:http://www.cnblogs.com/chengsheng/p/5380289.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!