码迷,mamicode.com
首页 > Windows程序 > 详细

POJ 2585.Window Pains

时间:2016-04-14 14:17:21      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:

 

Window Pains
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1888   Accepted: 944

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux‘s windows would be represented by the following 2 x 2 windows: 
1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?
. . . and so on . . . 
Unfortunately, Boudreaux‘s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux‘s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux‘s screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

 题目链接:http://poj.org/problem?id=2585

题意:有9个窗口把一个窗口调到最前面,它的所有的方格都位于最前面,覆盖其他窗口与它公用的方格。输入所有的方格的状态,判断是否正确。

思路:标准的窗口覆盖表格:

1 1,2 2,3 3
1,4 1,2,4,5 2,3,5,6 3,6
4,7 4,5,7,8 5,6,8,9 6,9
7 7,8 8,9 9

每个方格的数字,会覆盖它前面的数字。根据覆盖构建一个有向图。判断输入的数据所形成的有向图是否形成一个环,这就是拓扑排序里面判断是否有环的问题。

首先在输入之前,构建好标准覆盖。

 

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int L[10][10];
int indegree[10];
int TopSort();
int main()
{
    int i,j,t;
    string cover[5][5];
    for(i=0; i<3; i++)
    {
        for(j=0; j<3; j++)
        {
            cover[i][j]+=j+1+i*3+‘0‘;
            cover[i][j+1]+=j+1+i*3+‘0‘;
            cover[i+1][j]+=j+1+i*3+‘0‘;
            cover[i+1][j+1]+=j+1+i*3+‘0‘;
        }
    }
    /**
    for(i=0; i<4; i++)
    {
        for(j=0; j<4; j++)
        {
            string::iterator y;
            for (y=cover[i][j].begin(); y!=cover[i][j].end(); ++y)
            {
                cout<<*y;
            }
            cout<<" ";
        }
        cout<<endl;
    }
    */
    string s;
    while(cin>>s)
    {
        getchar();
        if(s=="ENDOFINPUT") break;
        memset(indegree,0,sizeof(indegree));
        memset(L,0,sizeof(L));
        for(i=0; i<4; i++)
        {
            for(j=0; j<4; j++)
            {
                char x;
                scanf("%c",&x);
                string::iterator y; //指向STRING的迭代器,其实和指针的概念是一样。
                for (y=cover[i][j].begin(); y!=cover[i][j].end(); ++y)
                {
                    if((*y)!=x&&L[x-‘0‘][(*y)-‘0‘]==0)
                    {
                        L[x-‘0‘][(*y)-‘0‘]=1;
                        indegree[(*y)-‘0‘]++;
                    }
                }
                getchar();
            }
        }
        cin>>s;
        getchar();
        /**
        for(i=1; i<10; i++)
        {
            cout<<i<<":";
            for(j=0; j<10; j++)
            {
                if(L[i][j]==1)
                    cout<<j<<" ";
            }
            cout<<endl;
        }
        cout<<"indegree:";
        for(i=1; i<10; i++) cout<<indegree[i]<<" ";
        cout<<endl;
        */
        int flag=TopSort();
        if(flag) cout<<"THESE WINDOWS ARE CLEAN"<<endl;
        else cout<<"THESE WINDOWS ARE BROKEN"<<endl;
    }
    return 0;
}
int TopSort()
{
    int i,j;
    int n=9;
    int sign=0;
    while(n--)
    {
    	sign=0;
        for(i=1; i<10; i++)
        {
            if(indegree[i]==0) sign=i;
        }
        if(sign>0)
        {
            for(j=0; j<10; j++)
            {
                if(L[sign][j])
                    indegree[j]--;
            }
            indegree[sign]=-1;
        }
        else if(sign==0) return 0;
    }
    return 1;
}

  

POJ 2585.Window Pains

标签:

原文地址:http://www.cnblogs.com/GeekZRF/p/5390774.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!