码迷,mamicode.com
首页 > Web开发 > 详细

HDU - 1061 Rightmost Digit

时间:2014-07-29 14:47:28      阅读:270      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   os   io   for   2014   div   

Description

Given a positive integer N, you should output the most right digit of N^N.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output

For each test case, you should output the rightmost digit of N^N.
 

Sample Input

2 3 4
 

Sample Output

7 6

题意:取N^N的最后一位

思路:裸的快速幂取模

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;

int pow_mod(int a, int n, int m) {
	if (n == 0)
		return 1;
	if (n == 1)
		return a%m;
	int x = pow_mod(a, n/2, m);
	ll ans = (ll) x*x%m;
	if (n % 2 == 1)
		ans = ans * a % m;
	return (int)ans;
}

int main() {
	int t;
	int n;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		ll ans = pow_mod(n, n, 10);
		cout << ans << endl;
	}
	return 0;
}



HDU - 1061 Rightmost Digit,布布扣,bubuko.com

HDU - 1061 Rightmost Digit

标签:des   style   blog   os   io   for   2014   div   

原文地址:http://blog.csdn.net/u011345136/article/details/38235291

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!