码迷,mamicode.com
首页 > Windows程序 > 详细

2011年浙大:Twin Prime Conjecture

时间:2016-04-17 22:09:51      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2659    Accepted Submission(s): 906


Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

 

Sample Input
1
5
20
-2
 
Sample Output
0
1
4
求区间素数,注意打表
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=100005;
bool isPrime[MAXN];
int cnt[MAXN];
int main()
{
    int n;
    memset(isPrime,true,sizeof(isPrime));
    for(int i=2;i<MAXN;i++)
    {
        if(isPrime[i])
        {    
            for(int j=i+i;j<MAXN;j+=i)
                isPrime[j]=false;
        }
    }
    cnt[5]=1;
    int pre=5;
    int num=1;
    for(int i=6;i<MAXN;i++)
    {
        if(isPrime[i])
        {
            if(i-pre==2)
            {
                num++;
            }
            pre=i;
        }
        cnt[i]=num;
    }
    while(scanf("%d",&n)!=EOF&&n>=0)
    {    
        printf("%d\n",cnt[n]);
    }
    return 0;
}

 

2011年浙大:Twin Prime Conjecture

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5402358.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!