码迷,mamicode.com
首页 > 移动开发 > 详细

[Poj 2486] Apple Tree 树形DP

时间:2016-04-19 19:41:41      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9069 Accepted: 3016

Description
Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input
There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output
For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

Source
POJ Contest,Author:magicpig@ZSU

题目链接http://poj.org/problem?id=2486

题意
一颗树,n个点(1-n),n-1条边,每个点上有一个权值,求从1出发,走V步,最多能遍历到的权值;

思路
树形DP;
dp[i][j][0/1]表示在i的子树下走j步(回到i点用1表示);

dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][1]+dp[y][t-1][0]);//先回x点(-1);
dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][0]+dp[y][t-2][1]);//先回y点-》x点(-2);
dp[x][j][1]=max(dp[x][j][1],dp[x][j-t][1]+dp[y][t-2][1]);//回到x点必回y点(-2)

代码

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
int dp[205][405][2];
int n,k;
vector<int> lin[205];
void dfs(int x,int pre)
{


    for(int i=0;i<lin[x].size();i++)
    {
        int y=lin[x][i];
        if(y==pre) continue;
        dfs(y,x);

        for(int j=k;j>=1;j--)
        for(int t=1;t<=j;t++)
        {
            dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][1]+dp[y][t-1][0]);
            dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][0]+dp[y][t-2][1]);
            dp[x][j][1]=max(dp[x][j][1],dp[x][j-t][1]+dp[y][t-2][1]);
        }
    }

}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int aa,bb;
        for(int i=1;i<=n;i++)
        {
            lin[i].clear();
            scanf("%d",&aa);
            for(int j=0;j<=k;j++)
            {
                dp[i][j][0]=dp[i][j][1]=aa;
            }
        }
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&aa,&bb);
            lin[aa].push_back(bb);
            lin[bb].push_back(aa);
        }
        dfs(1,0);
        printf("%d\n",max(dp[1][k][0],dp[1][k][1]));
    }


}

[Poj 2486] Apple Tree 树形DP

标签:

原文地址:http://blog.csdn.net/alps233/article/details/51193014

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!