码迷,mamicode.com
首页 > 系统相关 > 详细

HDU 5670 Machine

时间:2016-04-29 17:41:25      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:

Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 426    Accepted Submission(s): 257


Problem Description
There is a machine with m(2m30)技术分享 coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too.

Initally all the bulbs are red. What colour are the bulbs after the button be
pushed n(1n<2技术分享63技术分享)技术分享 times?
 

Input
There are multiple test cases. The first line of input contains an integer T(1T15)技术分享 indicating the number of test cases. For each test case:

The only line contains two integers m(2m30)技术分享 and n(1n<2技术分享63技术分享)技术分享.
 

Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 

Sample Input
2 3 1 2 3
 

Sample Output
RRG GR
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5674 5673 5672 5671 5669 
 类似于三进制。。。当时为什么我就没想起来呢技术分享
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	char s[3]={'R','G','B'},ans[32];
	int t,m,i;
	__int64 n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%I64d",&m,&n);
		for(i=m;i>0;i--)
		{
			ans[i]=s[n%3];
			n=n/3;
		}
		for(i=1;i<=m;i++)
		printf("%c",ans[i]);
		printf("\n");
	}
	return 0;
}


HDU 5670 Machine

标签:

原文地址:http://blog.csdn.net/yao1373446012/article/details/51249629

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!