码迷,mamicode.com
首页 > Windows程序 > 详细

poj 2823 Sliding Window 单调队列或线段树

时间:2014-07-31 13:26:26      阅读:308      评论:0      收藏:0      [点我收藏+]

标签:poj   单调队列   acm   算法   

题目链接:http://poj.org/problem?id=2823


Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 38315   Accepted: 11350
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

[Submit]   [Go Back]   [Status]   [Discuss]

bubuko.com,布布扣Home Page   bubuko.com,布布扣Go Back  bubuko.com,布布扣To top



这道题可以用线段树和单调队列两种方法来完成。

如果用线段树的话可以让节点保存最大值和最小值即可。然后在  query(i,i+m)即可。

        for(int i=1;i<=m;i++)  
        {  
            query(i,i+m,mint,maxt,1);  
            minl[i]=mint;  
            maxl[i]=maxt;  
        }  


也可以用单调队列。单调队列是这样一个队列,队列中的所有元素是单调递增或者单调递减。它可以在队首或队尾删除元素,但是只能在队尾插入元素。由于每个元素入队和出队一次,所以维护队列的均摊时间复杂度为O(1)。

//这题在poj里得用C++交
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<vector>
#include<bitset>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<cstdlib>
using namespace std;
#define CLR(A) memset(A,0,sizeof(A))
const int MAX=1000005;
int n,m;
int a[MAX],q[MAX];
void minq(){
    int tail=0,head=1;
    for(int i=1;i<=n;i++){
        while(head<=tail&&a[q[tail]]>=a[i]) tail--;
        q[++tail]=i;
        if(i>=m){
            while(q[head]<i-m+1) head++;//判断是否过时。
            printf("%d ",a[q[head]]);
        }
    }
    printf("\n");
}
void maxq(){
    int tail=0,head=1;
    for(int i=1;i<=n;i++){
        while(head<=tail&&a[q[tail]]<=a[i]) tail--;
        q[++tail]=i;
        if(i>=m){
            while(q[head]<i-m+1) head++;//判断是否过时。
            printf("%d ",a[q[head]]);
        }
    }
    printf("\n");
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    minq();maxq();
    return 0;
}


poj 2823 Sliding Window 单调队列或线段树,布布扣,bubuko.com

poj 2823 Sliding Window 单调队列或线段树

标签:poj   单调队列   acm   算法   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/38313497

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!