码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 1053 Integer Inquiry (大数加法,还是Java大法好)

时间:2016-05-14 01:08:26      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:

Integer Inquiry
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32674   Accepted: 12789

Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source



PS:变形的大数加法,还是Java 好!

AC代码:

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			BigInteger sum = new BigInteger("0",10);
			BigInteger x = sc.nextBigInteger();
			if(x.equals(new BigInteger("0"))){//注意,与'0'判断时要new对象!!!
				System.out.println(sum);
				break;
			}
			sum = sum.add(x);
		}

	}

}

AC代码2;

#include <stdio.h>
#include <string.h>
char a[1000];
int sum[1000],data[1000];
int length_sum;
int main()
{
    int i,j,length_a,jin,temp;
    memset(sum,0,sizeof(sum));
    while(1)
    {
        scanf("%s",a);
        length_a=strlen(a);
        if (a[0]=='0'&&length_a==1)
        {
            length_sum=999;
            while(sum[length_sum]==0)
            {
                length_sum--;
            }
            for (i=length_sum; i>=0; i--)
            {
                printf("%d",sum[i]);
            }
            break;
        }
        else
        {
            memset(data,0,sizeof(data));
            for (j=0,i=length_a-1; i>=0; i--)
            {
                data[j++]=a[i]-'0';
            }
            for(jin=0,i=0; i<1000; i++)
            {
                temp=sum[i]+data[i]+jin;
                sum[i]=temp%10;
                jin=temp/10;
            }
        }
    }
    return 0;
}



POJ 1053 Integer Inquiry (大数加法,还是Java大法好)

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/51399731

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!