码迷,mamicode.com
首页 > Web开发 > 详细

hdu1045Fire Net (一行变多行,一列变多列,最小顶点覆盖)

时间:2014-08-01 13:44:41      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:二分匹配

Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6280 Accepted Submission(s): 3549


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

bubuko.com,布布扣

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0

Sample Output
5 1 5 2 4
PS:以前想用DFS做,但没有做出来,还是觉得二分匹配算法好用。
#include<stdio.h>
#include<string.h>
int map[50][50],vist[50],match[50],ln,rn;
int find(int i)
{
    for(int j=1;j<=ln;j++)
    if(map[i][j]&&!vist[j])
    {
        vist[j]=1;
        if(match[j]==0||find(match[j]))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int n,mpr[5][5],mpl[5][5];
    char s;
    while(scanf("%d",&n)>0&&n)
    {
        memset(mpr,0,sizeof(mpr));
        memset(mpl,0,sizeof(mpl));
        for(int i=1;i<=n;i++)
        {
            getchar();
            for(int j=1;j<=n;j++)
            {

                scanf("%c",&s);
                if(s=='X')
                mpr[i][j]=mpl[i][j]=-1;
            }
        }
        rn=0;
        for(int i=1;i<=n;i++)//一行变多行
        for(int j=1;j<=n;j++)
        {
            while(mpr[i][j]==-1&&j<=n)j++;
            rn++;
            while(mpr[i][j]!=-1&&j<=n)
            {
                mpr[i][j]=rn; j++;
            }
        }
        ln=0;
        for(int j=1;j<=n;j++)//一列变多列
        for(int i=1;i<=n;i++)
        {
            while(mpl[i][j]==-1&&i<=n)i++;
            ln++;
            while(mpl[i][j]!=-1&&i<=n)
            {
                mpl[i][j]=ln; i++;
            }
        }
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)//行列建图
        for(int j=1;j<=n;j++)
        if(mpr[i][j]!=-1)
        map[mpr[i][j]][mpl[i][j]]=1;
        
        memset(match,0,sizeof(match));
        int ans=0;
        for(int i=1;i<=rn;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",ans);
    }
}


hdu1045Fire Net (一行变多行,一列变多列,最小顶点覆盖),布布扣,bubuko.com

hdu1045Fire Net (一行变多行,一列变多列,最小顶点覆盖)

标签:二分匹配

原文地址:http://blog.csdn.net/u010372095/article/details/38333767

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!