码迷,mamicode.com
首页 > 编程语言 > 详细

poj3624背包问题(一维数组)

时间:2016-07-29 17:13:03      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

 

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
#define Maxn 14000
int Val[Maxn];

int bag(int val[],int weight[],int M,int N)
{
    memset(Val,0,sizeof(Val));
    int maxn = 0;
    for(int i = 1; i <= N; i++)
    {
        for(int j = M; j >= weight[i]; j--)
        {
            if (Val[j] < (Val[j - weight[i]] + val[i]))
            {
                Val[j] = max(Val[j],Val[j - weight[i]] + val[i]);
            }
        }
    }
    return Val[M];
}



int main()
{
    int N,M;
    int val[Maxn];
    int weight[Maxn];
    scanf("%d%d",&N,&M);
    for(int i = 1; i <= N; i++)
    {
        scanf("%d",weight+i);
        scanf("%d",val+i);
    }
    printf("%d\n",bag(val,weight,M,N));
    return 0;
}

  

poj3624背包问题(一维数组)

标签:

原文地址:http://www.cnblogs.com/yakoazz/p/5718911.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!