标签:
题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1686
题目:
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
思路:裸的kmp应用。不过一开始把next数组开的1e6次方的大小,然后多组数据时每次memmset一下,然后就T了。。把数组大小改成1e4后,变成146MS了。。。。
今天算是第二次体会到memset的恐怖耗时了。
#include <bits/stdc++.h>
#define PB push_back
#define MP make_pair
using namespace std;
typedef long long LL;
typedef pair<int,int> PII;
#define PI acos((double)-1)
#define E exp(double(1))
#define K 1000000+9
int nt[10000+1];
char a[K],b[10001];
void kmp_next(void)
{
memset(nt,0,sizeof(nt));
for(int i=1,j=0,m=strlen(b);i<m;i++)
{
while(j&&b[i]!=b[j])j=nt[j-1];
if(b[i]==b[j])j++;
nt[i]=j;
}
}
int kmp(void)
{
kmp_next();
int ans=0;
for(int i=0,j=0,n=strlen(a);i<n;i++)
{
while(j&&a[i]!=b[j])j=nt[j-1];
if(a[i]==b[j])j++;
if(j==strlen(b))
ans++;
}
return ans;
}
int main(void)
{
int t;cin>>t;
while(t--)
{
scanf("%s%s",b,a);
printf("%d\n",kmp());
}
return 0;
}
hdu 1686 Oulipo kmp算法
标签:
原文地址:http://www.cnblogs.com/weeping/p/5731071.html