码迷,mamicode.com
首页 > Web开发 > 详细

poj---2349---Arctic Network

时间:2016-08-04 22:47:11      阅读:261      评论:0      收藏:0      [点我收藏+]

标签:

poj---2349---Arctic Network
 

Time Limit:

2000MS

  Memory Limit: 65536K
Total Submissions: 16619   Accepted: 5294
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 
 
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1 2 4 0 100 0 300 0 600 150 750
Sample Output
212.13
Source
 
 
注意题中已经说明:所有哨所的收发器必须是相同的;那就是说,D值对每一个哨所相同。
而且使用无线电通讯的要求是当两个哨所之间的距离不超过D时可以通过无线电通讯。
所以找出除去使用卫星频道的最大的那个距离。
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include<algorithm>
using namespace std;

const int maxn=11000;
const int INF=0x3f3f3f3f;

double maps[maxn][maxn], dist[maxn];
int vis[maxn];
double a[maxn];
int n, m, k;

void Init()
{
    k=0;
    memset(a, 0, sizeof(a));
    memset(vis, 0, sizeof(vis));

    for(int i=0; i<=n; i++)
    {
        for(int j=0; j<=n; j++)
            maps[i][j]=(i==j)?0:INF;
        dist[i]=INF;
    }
}

int cmp(const void *a, const void *b)
{
    return *(double *)a<*(double *)b?1:-1;
}
void prim()
{
    for(int i=1; i<=n; i++)
        dist[i]=maps[1][i];
    vis[1]=1;

    for(int i=1; i<n; i++)
    {
        double Min=INF;
        int index=-1;

        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dist[j]<Min)
            {
                Min=dist[j];
                index=j;
            }
        }

        a[k++]=Min;
        vis[index]=1;

        for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]>maps[index][j])
                dist[j]=maps[index][j];

    }
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &m, &n);
        Init();
        int x[maxn], y[maxn];
        for(int i=1; i<=n; i++)
            scanf("%d %d", &x[i], &y[i]);

        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                double d=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
                maps[i][j]=maps[j][i]=d;
            }
        }

        prim();
        sort(a, a+k);
        printf("%.2f\n", a[k-m]);
    }
    return 0;
}

 

 

poj---2349---Arctic Network

标签:

原文地址:http://www.cnblogs.com/w-y-1/p/5738473.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!