码迷,mamicode.com
首页 > 移动开发 > 详细

hdu 4925 Apple Tree--2014 Multi-University Training Contest 6

时间:2014-08-07 23:15:35      阅读:339      评论:0      收藏:0      [点我收藏+]

标签:2014 multi-universit   acm   算法   水题   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4925


Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 188    Accepted Submission(s): 129


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2 2 2 3 3
 

Sample Output
8 32
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  4929 4928 4926 4924 4923 
 

Statistic | Submit | Discuss | Note


签道题,没啥好说的,黑白染色的方法是最优的,特判1*1的情况


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
using namespace std;
#define CLR(A) memset(A,0,sizeof(A))
int A[110][110];
int main(){
    int T,m,n;
    cin>>T;
    while(T--){
        cin>>n>>m;
        if(n==1 && m==1){
            cout<<1<<endl;
            continue;
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                A[i][j]=1;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++){
                if(A[i][j]==1){
                    A[i-1][j]<<=1;
                    A[i+1][j]<<=1;
                    A[i][j-1]<<=1;
                    A[i][j+1]<<=1;
                }
            }
        long long sum=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++){
                if(A[i][j]!=1){
                    sum+=A[i][j];
                }
            }
        cout<<sum<<endl;
    }
    return 0;
}






hdu 4925 Apple Tree--2014 Multi-University Training Contest 6,布布扣,bubuko.com

hdu 4925 Apple Tree--2014 Multi-University Training Contest 6

标签:2014 multi-universit   acm   算法   水题   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/38425007

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!