码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 1102 Constructing Roads【简单最小生成树,Prime算法+Kruskal算法】

时间:2016-08-05 01:05:35      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20765    Accepted Submission(s): 7934


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102

直接套模板。


Prime算法AC代码:15ms

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int INF=0x3f3f3f3f;
int a[105][105];
int dis[105];
bool vis[105];
int n;

int Prime()
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=a[1][i];
        vis[i]=false;
    }
    dis[1]=0;
    vis[1]=true;
    int ans=0;
    for(int i=1;i<n;i++)
    {
        int minn=INF;
        int p=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<minn)
                minn=dis[p=j];
        }
        //if(p==-1)
            //return -1;
        ans+=minn;
        vis[p]=true;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]>a[p][j])
                dis[j]=a[p][j];
        }
    }
    return ans;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                scanf("%d",&a[i][j]);
        }
        int t,x,y;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&x,&y);
            a[x][y]=a[y][x]=0;
        }
        printf("%d\n",Prime());
    }
    return 0;
}

Kruskal算法AC代码:46ms

#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
    int s,e,w;
}a[5000];
int n,m;
int fa[105];
int Find(int x)
{
    if(x==fa[x])
        return x;
    return fa[x]=Find(fa[x]);
}
bool cmp(node a,node b)
{
    return a.w<b.w;
}
int Kruskal()
{
    sort(a,a+m,cmp);
    int ans=0;
    for(int i=0;i<m;i++)
    {
        int fx=Find(a[i].s);
        int fy=Find(a[i].e);
        if(fx!=fy)
        {
            ans+=a[i].w;
            fa[fx]=fy;
        }
    }
    return ans;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        m=0;
        int t;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&t);
                if(i<j)
                {
                    a[m].s=i;
                    a[m].e=j;
                    a[m++].w=t;
                }
            }
        }
        for(int i=1;i<=n;i++)
        fa[i]=i;
        scanf("%d",&t);
        int x,y;
        while(t--)
        {
            scanf("%d%d",&x,&y);
            int fx=Find(x);
            int fy=Find(y);
            if(fx!=fy)
                fa[fx]=fy;
        }
        printf("%d\n",Kruskal());
    }
    return 0;
}



HDU 1102 Constructing Roads【简单最小生成树,Prime算法+Kruskal算法】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52122443

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!