标签:
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5821
Ball
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 515 Accepted Submission(s): 309
Problem Description
ZZX has a sequence of boxes numbered 1,2,...,n.
Each box can contain at most one ball.
You are given the initial configuration of the balls. For 1≤i≤n,
if the i-th
box is empty then a[i]=0,
otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.
He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)
He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].
1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.
0<=a[i],b[i]<=n.
1<=l[i]<=r[i]<=n.
Output
For each testcase, print "Yes" or "No" in a line.
Sample Input
5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4
Sample Output
Author
学军中学
Source
题目大意:给两个长度为n的数组a和b,再给定m次操作,每次给定l和r,每次可以把[l,r]的数进行任意调换位置,问能否在转换后使得a数组变成b数组。
解题思路:用结构体存储a数组,值和下标,下标存的是a数组对应b数组之后的下标。然后在对a数组的下标进行排序,这样就会使a数组的值随着下标的变化而变换,尽可能使a和b相同的值对应好,最后在扫一遍看两个数组相同位置的数字是否相同,相同输出Yes,否则输出No。
详见代码。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
#define N 1010
struct node
{
int a,i;//值和下标
} s[N];
int b[N];
bool cmp(node a,node b)
{
return a.i<b.i;
}
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
int n,m,flag=1;
scanf("%d%d",&n,&m);
for (int i=0; i<n; i++)
{
scanf("%d",&s[i].a);
s[i].i=-1;
}
for (int i=0; i<n; i++)
{
scanf("%d",&b[i]);
for (int j=0; j<n; j++)
{
if (s[j].a==b[i]&&s[j].i==-1)
{
s[j].i=i;
break;
}
}
}
int l,r;
for (int i=0; i<m; i++)
{
scanf("%d%d",&l,&r);
sort(s+l-1,s+r,cmp);//根据s的下标进行排序
}
for (int i=0; i<n; i++)
{
if (b[i]!=s[i].a)
{
flag=0;
break;
}
}
if (flag==1)
printf ("Yes\n");
else
printf ("No\n");
}
return 0;
}
hdu 5821 Ball(2016 Multi-University Training Contest 8——贪心+排序)
标签:
原文地址:http://blog.csdn.net/qiqi_skystar/article/details/52190466