码迷,mamicode.com
首页 > Web开发 > 详细

HDU 5842 Lweb and String

时间:2016-08-15 17:20:05      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:

Lweb and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 368    Accepted Submission(s): 243


Problem Description
Lweb has a string S.

Oneday, he decided to transform this string to a new sequence. 

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

You need transform every letter in this string to a new number.

A is the set of letters of SB is the set of natural numbers. 

Every injection f:AB can be treat as an legal transformation. 

For example, a String “aabc”, A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

Now help Lweb, find the longest LIS which you can obtain from S.

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
 

 

Input
The first line of the input contains the only integer T,(1T20).

Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105.
 

 

Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
 

 

Sample Input
2 aabcc acdeaa
 

 

Sample Output
Case #1: 3
Case #2: 4
 

 

Author
UESTC
 

 

Source

 

 

解析:说了那么多,其实很简单,就是求有多少种字母。

 

 

 

#include <cstdio>
#include <cstring>

const int MAXN = 1e5+5;
char s[MAXN];
bool vis[30];

int main()
{
    int t, cn = 0;
    scanf("%d", &t);
    while(t--){
        scanf("%s", s);
        memset(vis, 0, sizeof(vis));
        int res = 0;
        for(int i = 0; s[i] != ‘\0‘; ++i){
            if(!vis[s[i]-‘a‘]){
                vis[s[i]-‘a‘] = true;
                ++res;
            }
        }
        printf("Case #%d: %d\n", ++cn, res);
    }
    return 0;
}

  

HDU 5842 Lweb and String

标签:

原文地址:http://www.cnblogs.com/inmoonlight/p/5773467.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!