码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 1511 Invitation Cards 【最短路,spfa算法,Dijkstra算法堆优化】

时间:2016-08-15 19:14:50      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:

Invitation Cards
Time Limit: 8000MS   Memory Limit: 262144K
Total Submissions: 25219   Accepted: 8346

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X‘ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

Source


原题链接:http://poj.org/problem?id=1511


参考博客:http://blog.csdn.net/wuyanyi/article/details/7286014

题意:

给定节点数n,和边数m,边是单向边.

问从1节点出发到2,3,...n 这些节点路程和从从这些节点回来到节点1的路程和最小值。

思路:

很显然的最短路,先以1为起点进行一次最短路,然后再将边反向一下再以1为起点进行一下最短路。

这题的意义在于数据,一般的dijstra的O(N^2)显然没法过。

dijstra+heap,其实heap直接用priority_queue实现即可

spfa算法AC代码;

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn=1000000+10;
typedef long long LL ;
const LL INF = 0x3f3f3f3f3f3f3f3f;
int n,m;
struct node
{
    int to,next,w;
} edge[maxn];
int head[maxn];
int a[maxn][3];
LL dis[maxn];
bool vis[maxn];
int cnt;
void addEdge(int u,int v,int w)
{
    edge[cnt].to=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
void Init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(vis,false,sizeof(vis));
    for(int i=0; i<=n; i++)
        dis[i]=INF;
}
LL spfa()
{
    queue<int>q;
    q.push(1);
    vis[1]=true;
    dis[1]=0;
    while(!q.empty())
    {
        int p = q.front();
        q.pop();
        vis[p] = false ;
        //注意spfa的vis和dijstra的不同点,
        //前者是判断是否在queue里而已
        //后者是判断是否已经是最优的点。
        for (int i=head[p]; i!=-1; i=edge[i].next)
        {
            int to = edge[i].to;
            int w = edge[i].w;
            if(dis[to]>dis[p]+w)
            {
                dis[to]=dis[p]+w;
                if(!vis[to])
                {
                    q.push(to);
                    vis[to]=true;
                }
            }
        }
    }
    LL ans = 0;
    for (int i=1; i<=n; i++)
    {
        ans+=dis[i];
    }
    return ans;
}
int main()
{
    int T;
    //freopen("data/1511.txt","r",stdin);
    cin>>T;
    int x,y,z;
    while(T--)
    {
        cin>>n>>m;
        Init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a[i][0],&a[i][1],&a[i][2]);
            addEdge(a[i][0],a[i][1],a[i][2]);
        }
        LL ans = spfa();
        Init();
        for(int i=0; i<m; i++)
        {
            addEdge(a[i][1],a[i][0],a[i][2]);
        }
        ans += spfa();
        cout<<ans<<endl;
    }
    return 0;
}


Dijkstra算法AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
const int maxn=1000000+10;
typedef long long LL ;
const LL INF = 0x3f3f3f3f3f3f3f3f;
int n,m;
struct node
{
    int to,next,w;
} edge[maxn];
int head[maxn];
int a[maxn][3];
LL dis[maxn];
bool vis[maxn];
int cnt;
void addEdge(int u,int v,int w)
{
    edge[cnt].to=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
void Init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(vis,false,sizeof(vis));
    for(int i=0; i<=n; i++)
        dis[i]=INF;
}
struct cmp
{
    //注意priority_queue的cmp写的和sort里面的cmp的区别,
    //前者是struct,后者是函数,
    //而且比较大小的关系刚好是相反的。
    bool operator() (const int a,const int b)
    {
        return dis[a]>dis[b];
    }
};
LL Dijkstra()
{
    priority_queue<int,vector<int>,cmp>q;
    dis[1] = 0;
    q.push(1);
    while(!q.empty())
    {
        int p = q.top();
        q.pop();
        vis[p] = true;
        for(int i=head[p]; i!=-1; i=edge[i].next)
        {
            int to=edge[i].to;
            int w=edge[i].w;
            //如果是可松弛点即加入优先队列,dis值越小越优先。
            if(!vis[to]&&dis[to]>dis[p]+w)
            {
                dis[to]=dis[p]+w;
                q.push(to);
            }
        }
    }
    LL ans = 0;
    for(int i=1; i<=n; i++)
        ans+=dis[i];
    return ans;
}
int main()
{
    int T;
    //freopen("data/1511.txt","r",stdin);
    cin>>T;
    int x,y,z;
    while(T--)
    {
        cin>>n>>m;
        Init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a[i][0],&a[i][1],&a[i][2]);
            addEdge(a[i][0],a[i][1],a[i][2]);
        }
        LL ans = Dijkstra();
        Init();
        for(int i=0; i<m; i++)
        {
            addEdge(a[i][1],a[i][0],a[i][2]);
        }
        ans += Dijkstra();
        cout<<ans<<endl;
    }
    return 0;
}



POJ 1511 Invitation Cards 【最短路,spfa算法,Dijkstra算法堆优化】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52211178

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!