码迷,mamicode.com
首页 > 编程语言 > 详细

Palindrome_滚动数组&&DP

时间:2016-09-16 22:38:02      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

 

 

【题意】给出一个字符串,求插入多少字符才能形成回文串;

【思路】用a数组存储原串,b数组储存倒串,求最长公共子序列,答案用n-最长公共子序列;

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=5050;
char a[N],b[N];
//int dp[N][N];//MLE
int dp[2][N];//用滚动数组
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        getchar();
        scanf("%s",a+1);
        for(int i=1;i<=n;i++)
        {
            b[n-i+1]=a[i];
        }
        memset(dp,0,sizeof(dp));
        int mx=0;
        /*for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[i]!=b[j])
                {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
                else dp[i][j]=dp[i-1][j-1]+1;
            }
        }*/
        int e=0;//用滚动数组,节约存储空间!!!!
        for(int i=1;i<=n;i++)
        {
            e=1-e;
            for(int j=1;j<=n;j++)
            {
                if(a[i]==b[j])
                {
                    dp[e][j]=dp[1-e][j-1]+1;
                }
                else
                {
                    if(dp[1-e][j]>dp[e][j-1])
                    {
                        dp[e][j]=dp[1-e][j];
                    }
                    else dp[e][j]=dp[e][j-1];
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            mx=max(mx,max(dp[1-e][i],dp[e][i]));
        }
        int ans=n-mx;
        printf("%d\n",ans);
    }
    return 0;
}

 

Palindrome_滚动数组&&DP

标签:

原文地址:http://www.cnblogs.com/iwantstrong/p/5877324.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!