码迷,mamicode.com
首页 > 编程语言 > 详细

HDU_1711_初识KMP算法

时间:2016-09-25 13:12:17      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22568    Accepted Submission(s): 9639


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 
 
KMP算法还需多理解。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
#include<cmath>
using namespace std;

int n,m;
int N[1000005],M[10005],Pi[10005];

void preFix()
{
    memset(Pi,0,sizeof(Pi));
    int k=0;
    for(int q=2;q<=m;q++)
    {
        while(k>0&&M[k+1]!=M[q])
            k=Pi[k];
        if(M[k+1]==M[q])
            k++;
        Pi[q]=k;
    }
}

int KMP()
{
    preFix();
    int q=0;
    for(int i=1;i<=n;i++)
    {
        while(q>0&&M[q+1]!=N[i])
            q=Pi[q];
        if(M[q+1]==N[i])
            q++;
        if(q==m)
            return i-m+1;
    }
    return -1;
}
int main() { int t; scanf("%d",&t); while(t--) { scanf("%d%d",&n,&m); for(int i=1;i<=n;i++) scanf("%d",&N[i]); for(int j=1;j<=m;j++) scanf("%d",&M[j]); int ans=KMP(); printf("%d\n",ans); } return 0; }

 

 
 

HDU_1711_初识KMP算法

标签:

原文地址:http://www.cnblogs.com/jasonlixuetao/p/5905636.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!