码迷,mamicode.com
首页 > Web开发 > 详细

http://acm.split.hdu.edu.cn/showproblem.php?pid=2255

时间:2016-09-27 16:26:45      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
传说在遥远的地方有一个非常富裕的村落,有一天,村长决定进行制度改革:重新分配房子。
这可是一件大事,关系到人民的住房问题啊。村里共有n间房间,刚好有n家老百姓,考虑到每家都要有房住(如果有老百姓没房子住的话,容易引起不安定因素),每家必须分配到一间房子且只能得到一间房子。
另一方面,村长和另外的村领导希望得到最大的效益,这样村里的机构才会有钱.由于老百姓都比较富裕,他们都能对每一间房子在他们的经济范围内出一定的价格,比如有3间房子,一家老百姓可以对第一间出10万,对第2间出2万,对第3间出20万.(当然是在他们的经济范围内).现在这个问题就是村领导怎样分配房子才能使收入最大.(村民即使有钱购买一间房子但不一定能买到,要看村领导分配的).
 

 

Input
输入数据包含多组测试用例,每组数据的第一行输入n,表示房子的数量(也是老百姓家的数量),接下来有n行,每行n个数表示第i个村名对第j间房出的价格(n<=300)。
 

 

Output
请对每组数据输出最大的收入值,每组的输出占一行。

 

 

Sample Input
2 100 10 15 23
 

 

Sample Output
123
 

 

AC代码:

 

#include<iostream>

#include<cstdio>

#include<cstring>

#include<climits>

#include<algorithm>

using namespace std;

#define N 310

int map[N][N];

bool visitx[N], visity[N];

int lx[N], ly[N];

int match[N];

int n;

 

bool Hungary(int u) //匈牙利算法

{

    visitx[u] = true;

    for(int i = 0; i < n; ++i)

    {

        if(!visity[i] && lx[u] + ly[i] == map[u][i])

        {

            visity[i] = true;

            if(match[i] == -1 || Hungary(match[i]))

            {

                match[i] = u;

                return true;

            }

        }

    }

    return false;

}

 

void KM_perfect_match()

{

    int temp;

    memset(lx, 0, sizeof(lx)); //初始化顶标

    memset(ly, 0, sizeof(ly)); //ly[i]为0

    for(int i = 0; i < n; ++i) //lx[i]为权值最大的边

        for(int j = 0; j < n; ++j)

            lx[i] = max(lx[i], map[i][j]);

    for(int i = 0; i < n; ++i) //对n个点匹配

    {

        while(1)

        {

            memset(visitx, false, sizeof(visitx));

            memset(visity, false, sizeof(visity));

            if(Hungary(i)) //匹配成功

                break;

            else //匹配失败,找最小值

            {

                temp = INT_MAX;

                for(int j = 0; j < n; ++j) //x在交错树中

                    if(visitx[j])

                        for(int k = 0; k < n; ++k) //y在交错树外

                            if(!visity[k] && temp > lx[j] + ly[k] - map[j][k])

                                temp = lx[j] + ly[k] - map[j][k];

                for(int j = 0; j < n; ++j) //更新顶标

                {

                    if(visitx[j])

                        lx[j] -= temp;

                    if(visity[j])

                        ly[j] += temp;

                }

            }

        }

    }

}

 

int main()

{

    int ans;

    while(scanf("%d", &n) != EOF)

    {

        ans = 0;

        memset(match, -1, sizeof(match));

        for(int i = 0; i < n; ++i)

            for(int j = 0; j < n; ++j)

                scanf("%d", &map[i][j]);

        KM_perfect_match();

        for(int i = 0; i < n; ++i) //权值相加

            ans += map[match[i]][i];

        printf("%d\n", ans);

    }

    return 0;

}

 

http://acm.split.hdu.edu.cn/showproblem.php?pid=2255

标签:

原文地址:http://www.cnblogs.com/a-clown/p/5913260.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!