码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 1804 Brainman(归并排序)

时间:2016-10-09 12:59:42      阅读:1196      评论:0      收藏:0      [点我收藏+]

标签:

传送门

Description

Background 
Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task. 

Problem 
Here‘s what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: 

Start with: 2 8 0 3 
swap (2 8) 8 2 0 3 
swap (2 0) 8 0 2 3 
swap (2 3) 8 0 3 2 
swap (8 0) 0 8 3 2 
swap (8 3) 0 3 8 2 
swap (8 2) 0 3 2 8 
swap (3 2) 0 2 3 8 
swap (3 8) 0 2 8 3 
swap (8 3) 0 2 3 8


So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: 

Start with: 2 8 0 3 
swap (8 0) 2 0 8 3 
swap (2 0) 0 2 8 3 
swap (8 3) 0 2 3 8


The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond‘s mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

Input

The first line contains the number of scenarios. 
For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

Output

Start the output for every scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

Sample Input

4
4 2 8 0 3
10 0 1 2 3 4 5 6 7 8 9
6 -42 23 6 28 -100 65537
5 0 0 0 0 0

Sample Output

Scenario #1:
3

Scenario #2:
0

Scenario #3:
5

Scenario #4:
0

思路

 最小相邻交换次数=逆序数

 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
const int maxn = 1005;
int sum = 0;
void merge_array(int array[],int left,int mid,int right)
{
	if (left >= right)	return;
	int i = left,j = mid + 1,k = 0;
	int *p;
	p = (int *)malloc((right-left+1)*sizeof(int));
	while (i <= mid && j <= right)
	{
		if (array[i] <= array[j])	p[k++] = array[i++];
		else	p[k++] = array[j++],sum += mid - i + 1;       //[i,mid]都能与array[j]形成逆序数
	}
	while (i <= mid)	p[k++] = array[i++];
	while (j <= right)	p[k++] = array[j++];
	for (i = 0;i < k;i++)	array[i+left] = p[i];
	free(p);
}

void merge_sort(int array[],int left,int right)
{
	if (left >= right)	return;
	int mid = left + ((right - left)>>1);
	merge_sort(array,left,mid);
	merge_sort(array,mid+1,right);
	merge_array(array,left,mid,right);
}

int main()
{
	int T,Case = 0;
	scanf("%d",&T);
	while (T--)
	{
		int N,a[maxn];
		scanf("%d",&N);
		for (int i = 0;i < N;i++)	scanf("%d",&a[i]);
		sum = 0;
		merge_sort(a,0,N-1);
		printf("Scenario #%d:\n%d\n\n",++Case,sum);
	} 
	return 0;
}

  

POJ 1804 Brainman(归并排序)

标签:

原文地址:http://www.cnblogs.com/zzy19961112/p/5941169.html

(0)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!