码迷,mamicode.com
首页 > 数据库 > 详细

Database,Uva1592

时间:2016-10-27 10:16:38      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:nal   including   databases   amp   empty   comm   box   扫描   data   

Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.

There are different normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author‘s email.

If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter‘s Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

 

How to compete in ACM ICPC Peter peter@neerc.ifmo.ru
How to win ACM ICPC Michael michael@neerc.ifmo.ru
Notes from ACM ICPC champion Michael michael@neerc.ifmo.ru

The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.

Given a table your task is to figure out whether it is in PNF or not.

 

Input 

Input contains several datasets. The first line of each dataset contains two integer numbers n and m ( 1n10000, 1m10), the number of rows and columns in the table. The following n lines contain table rows. Each row has m column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).

 

Output 

For each dataset, if the table is in PNF write to the output file a single word ``YES" (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``NO" (without quotes). On the second line write two integer row numbers r1 and r2 ( 1r1r2nr1r2), on the third line write two integer column numbers c1 and c2 ( 1c1c2mc1c2), so that values in columns c1and c2 are the same in rows r1 and r2.

 

Sample Input 

 

3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru

 

Sample Output 

 

NO
2 3
2 3
YES


思路:

1.首先将每一个表格里面的字符串用map进行编号处理
2.一行一行的扫描,每两列的编号作为一个二元组存入map中,若已经存在该编号则说明有满足条件的,需要输出。


#include <iostream>
#include <string>
#include <set>
#include <vector>
#include <map>

using namespace std;

const int ROW = 10000 + 10;
const int COL = 10 + 5;
int n,m;
int s[ROW][COL];
map<string, int> IDcache;

struct node
{
    int x,y;
    node(int x, int y):x(x),y(y) { }
    bool operator < (const node& r) const { return x<r.x || x==r.x&&y<r.y; }
};

map<node,int> data;


int main()
{
    int n,m;
    int ID=1;
    cin>>n>>m;
    string x;

    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
             cin>>x;
             if(!IDcache.count(x)){
                 IDcache[x]=ID;
                 s[i][j]=ID;
                 ID++;
             }
             else{
                s[i][j]=IDcache[x];
             }
        }
    }

    int flag=0;
        for(int c1=0;c1<m;c1++){
        for(int c2=c1+1;c2<m;c2++){
                data.clear();
                for(int r=0;r<n;r++){

                    int x = s[r][c1];
                    int y = s[r][c2];
                    node p(x,y);
                    if(!data.count(p)){
                        data[p]=r;
                    }
                    else
                    {
                        flag=1;
                        cout<<"NO"<<endl;
                        cout<<data[p]+1<<" "<<r+1<<endl<<c1+1<<" "<<c2+1<<endl;

                    }

                }
        }
    }

    if(flag==0)
    {
      cout<<"YES";
    }

    cout<data++<<endl;
        return 0;
}

 

 

出错的地方:

由于map键值的存放是需要比较的,所以需要在node这个二元组里面重载比较符号<

Database,Uva1592

标签:nal   including   databases   amp   empty   comm   box   扫描   data   

原文地址:http://www.cnblogs.com/Qmelbourne/p/6002744.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!