码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2352 Stars(树状数组)

时间:2016-11-22 23:14:45      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:center   mem   maps   order   ons   cst   and   bool   lang   

                                                                 Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 44309   Accepted: 19236

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0
【分析】很常规的做法,先排序后树状数组统计。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#define inf 2e9
#define met(a,b) memset(a,b,sizeof a)
typedef long long ll;
using namespace std;
const int N = 2e5+5;
const int M = 4e5+5;
int n,m,tot=0,cnt=0;
int head[N],ans[N];
int tree[33000];
struct man{
    int x,y;
    bool operator< (const man &it)const{
        if(x==it.x)return y<it.y;
        return x<it.x;
    }
}a[N];
void add(int k,int num){
    while(k<=32001){
        tree[k]+=num;
        k+=k&(-k);
    }
}
int Sum(int k){
    int sum=0;
    while(k>0){
        sum+=tree[k];
        k-=k&(-k);
    }
    return sum;
}
int main() {
    met(tree,0);met(head,-1);met(ans,0);
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d%d",&a[i].x,&a[i].y);
        a[i].x++;a[i].y++;
    }
    sort(a+1,a+1+n);
    for(int i=1;i<=n;i++){
        int sum=Sum(a[i].y);
        ans[sum]++;
        add(a[i].y,1);
    }
    for(int i=0;i<n;i++)printf("%d\n",ans[i]);
    return 0;
}

 

POJ 2352 Stars(树状数组)

标签:center   mem   maps   order   ons   cst   and   bool   lang   

原文地址:http://www.cnblogs.com/jianrenfang/p/6091160.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!