码迷,mamicode.com
首页 > Web开发 > 详细

POJ 1258 Agri-Net

时间:2014-08-18 12:37:04      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:algorithm   prim   acm   poj   

来源:http://poj.org/problem?id=1258

归类: 图论、最小生成树、Prim

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40209   Accepted: 16380

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source


题意:略。

题解: Prim模板题~~ 开始敲一个提交超时,特别郁闷~~  扔了几天,今天又看下,改一个程序终止条件就AC了。
原来题目是默认EOF结束,我却自以为是的当做以0结束~~

AC代码:
#include<cstdio>
const int INF=1000000000; 
int n,map[105][105],wage;
bool pa[105],pb[105];int pos;
void Prim(){
	while(pos--){
		int min=INF,x=0,y=0;
		for(int i=1;i<=n;i++)
			if(pa[i])
			for(int j=1;j<=n;j++)
			if(pb[j]&&map[i][j]&&min>map[i][j]){
				min=map[i][j];x=i;y=j;
			}
		pb[y]=false;pa[y]=true;
		wage+=min;
		map[x][y]=0;map[y][x]=0;
	}
}
int main(){
	while(~scanf("%d",&n)){
	wage=0;
	for(int i=1;i<=n;i++) {
		pa[i]=false; pb[i]=true;
	} pa[1]=true;pb[1]=false; pos=n-1;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		scanf("%d",&map[i][j]);
	Prim();
	printf("%d\n",wage);
	}
	return 0;
} 



自己敲的代码,有些繁琐,下面贴一个小kd的模板

#include <iostream>
#include <cstring>
using namespace std;

const int V=110;
const int MAXINT=0x3f3f3f3f;

int map[V][V],dist[V],vist[V];
int n,i,j,m,minn,ans;

int main()
{
	while (cin>>n){
		ans=0;
		memset(vist,0,sizeof(vist));
		for (i=1;i<=n;++i)
			for (j=1;j<=n;++j)
				cin>>map[i][j];
		for (i=1;i<=n;++i)
			dist[i]=map[1][i];
		vist[1]=1;
	
		for (i=1;i<n;++i){
			minn=MAXINT;
			for (j=1;j<=n;++j)
				if (!vist[j] && dist[j]<minn){
					minn=dist[j]; m=j;
				}
			ans+=minn;
			for (j=1;j<=n;++j)
				dist[j]=dist[j]>map[m][j]?map[m][j]:dist[j];
			vist[m]=1;
		}
		cout<<ans<<endl;
	}
		return 0;
}





POJ 1258 Agri-Net,布布扣,bubuko.com

POJ 1258 Agri-Net

标签:algorithm   prim   acm   poj   

原文地址:http://blog.csdn.net/mummyding/article/details/38656733

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!