码迷,mamicode.com
首页 > Web开发 > 详细

P1546 最短网络 Agri-Net

时间:2017-01-07 20:47:23      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:数组   输入输出格式   输入输出   长度   com   color   namespace   struct   log   

题目背景

农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。

题目描述

约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。

你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000

输入输出格式

输入格式:

 

第一行: 农场的个数,N(3<=N<=100)。

第二行..结尾: 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。

 

输出格式:

 

只有一个输出,其中包含连接到每个农场的光纤的最小长度。

 

输入输出样例

输入样例#1:
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
输出样例#1:
28

说明

题目翻译来自NOCOW。

USACO Training Section 3.1

kruskal板子题。点击传送 

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>

using namespace std;

struct node{
    int x,y,z;
}e[10001];
int fa[10001];
int i,j,n,a,tot,ans;
bool cmp(node a,node b)
{
    return a.z<b.z;
}
int find(int k)
{
    if(fa[k]==k) return k;
    else return find(fa[k]);
}
int main()
{
    cin>>n;
    for(i=1;i<=n;++i)
    {
        for(j=1;j<=n;++j)
        {
            cin>>a;
            if(a)
            {
                tot++;
                e[tot].x=i;
                e[tot].y=j;
                e[tot].z=a;
            }
        }
    }
    int t=0;
    for(i=1;i<=n;++i) fa[i]=i;
    sort(e+1,e+1+tot,cmp);
    for(i=1;i<=tot;++i)
    {
        int fx=find(e[i].x),fy=find(e[i].y);
        if(fx!=fy)
        {
            fa[fy]=fx;
            ans+=e[i].z;
            t++;
        }
        if(t==n-1) break;
    }
    cout<<ans;
}

 

P1546 最短网络 Agri-Net

标签:数组   输入输出格式   输入输出   长度   com   color   namespace   struct   log   

原文地址:http://www.cnblogs.com/ruojisun/p/6260236.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!