码迷,mamicode.com
首页 > 移动开发 > 详细

开发中遇到的问题(一)——java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.

时间:2017-01-09 23:06:52      阅读:28      评论:0      收藏:0      [点我收藏+]

标签:tac   man   his   log   style   sof   ack   研究   port   

1、错误描述:

  java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.

2、起因:

  在Manifest中设置我的activity全屏


1 <activity android:name=".SplashActivity"
2             android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen">


3、原因:
  从错误提示中提到Theme.AppCompat theme,这是因为我们的activity一定是继承了兼容包中的类,比如我这里就无意中继承了AppCompatActivity,它来自android.support.v7.app.AppCompatActivity。

4、解决:

  改为继承自Activity,即来自import android.app.Activity。

(而继续继承AppCompatActivity该如何解决还有待研究。)

开发中遇到的问题(一)——java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.

标签:tac   man   his   log   style   sof   ack   研究   port   

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!