码迷,mamicode.com
首页 > 数据库 > 详细

poj3255 Roadblocks

时间:2017-01-25 21:14:14      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:sid   sea   ber   and   mst   share   because   moved   str   

Roadblocks
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13594   Accepted: 4783

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 
Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

[Submit]   [Go Back]   [Status]   [Discuss]

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <map>
#define for(i,x,n) for(int i=x;i<n;i++)
#define ll long long int
#define INF 0x3f3f3f3f
#define MOD 1000000007

using namespace std;

int MAX_V,MAX_E;
struct edge{int to,cost;};
typedef pair<int,int> P;//最短距离,编号
vector<edge> G[5005];
int d[5005];//最短距离
int d2[5005];//次短距离

void dijkstra(int s){
    priority_queue<P,vector<P>,greater<P> > que;
    fill(d,d+MAX_V,INF);
    fill(d2,d2+MAX_V,INF);
    d[s]=0;
    que.push(P(d[s],s));
    while(!que.empty()){
        P p=que.top(); que.pop();
        int v=p.second;
        for(i,0,G[v].size()){
            int to=G[v][i].to;
            int dd=p.first+G[v][i].cost;
            if(dd<d[to]){
                d[to]^=dd;
                dd^=d[to];
                d[to]^=dd;
                que.push(P(d[to],to));
            }
            if(dd<d2[to] && dd>d[to]){
                d2[to]=dd;
                que.push(P(d2[to],to));
            }
        }
    }
}

int main()
{
    int x,y,z;
    scanf("%d %d",&MAX_V,&MAX_E);
    for(i,0,MAX_E){
        scanf("%d %d %d",&x,&y,&z);
        x-=1;
        y-=1;
        edge ee;
        ee.to=y; ee.cost=z;
        G[x].push_back(ee);
        ee.to=x; ee.cost=z;
        G[y].push_back(ee);
    }
    dijkstra(0);
    printf("%d",d2[MAX_V-1]);
    return 0;
}

 

poj3255 Roadblocks

标签:sid   sea   ber   and   mst   share   because   moved   str   

原文地址:http://www.cnblogs.com/TWS-YIFEI/p/6349975.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!