码迷,mamicode.com
首页 > 编程语言 > 详细

acm专题---拓扑排序+优先队列

时间:2017-02-14 14:58:04      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:const   ++   esc   cpp   优先队列   排序   bottom   没有   struct   

 

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1285

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

 

Sample Input
4 3 1 2 2 3 4 3
 

 

Sample Output
1 2 4 3

 

 

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<stack>
#include<fstream>
#include<queue>
#include<string.h>
#include<list>
#include<map>
using namespace std;
const int maxnum = 501;
bool graph[maxnum][maxnum];
int in[maxnum];
struct cmp
{
	bool operator()(int a, int b)
	{
		return a > b;
	}
};
int main()
{
	int n, m;
	while (cin >> n >> m)
	{

		memset(graph, false, sizeof(graph));
		memset(in, 0, sizeof(in));

		for (int i = 0; i < m; i++)
		{
			int x, y;
			cin >> x >> y;
			if (graph[x][y])
				continue;
			graph[x][y] = true;
			in[y]++;
		}
		priority_queue<int, vector<int>, cmp> myque;
		for (int i = 1; i <= n; i++)
		{
			if (in[i] == 0)
				myque.push(i);
		}
		int cnt = 0;
		while (!myque.empty())
		{
			int tmptop = myque.top();
			cnt++;
			if (cnt != n)
				cout << tmptop << " ";
			else cout << tmptop << endl;
			myque.pop();
			in[tmptop] = -1;
			for (int i = 1; i <= n; i++)
			{
				if (graph[tmptop][i])
				{
					in[i]--;
					if (in[i] == 0)
						myque.push(i);
				}
			}
		}
	}
	return 0;
}
/*
5 3
1 4
4 3
2 5

1 2 4 3 5
*/

  

acm专题---拓扑排序+优先队列

标签:const   ++   esc   cpp   优先队列   排序   bottom   没有   struct   

原文地址:http://www.cnblogs.com/wuxiangli/p/6397250.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!