码迷,mamicode.com
首页 > Web开发 > 详细

zoj QS 1586 Network (prim算法)

时间:2014-08-20 16:27:32      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:style   http   color   os   io   strong   for   ar   

QS Network

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS‘s have received the message.

A sample is shown below:

bubuko.com,布布扣


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS‘s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS‘s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


最小生成树,把每条边的两个端点加上顶点值就行了。


#include"stdio.h"
#include"string.h"
#include"iostream"
#include"queue"
#include"algorithm"
using namespace std;
#define N 1005
const int inf=0x3fffffff;
int g[N][N],a[N],dis[N];
bool mark[N];
void prim(int s,int n)
{
    int i,j,u,min,sum=0;
    memset(mark,0,sizeof(mark));
    mark[s]=1;
    for(i=0;i<n;i++)
    {
        dis[i]=g[s][i];
    }
    for(j=1;j<n;j++)
    {
        min=inf;
        u=s;
        for(i=0;i<n;i++)
        {
            if(!mark[i]&&dis[i]<min)
            {
                min=dis[i];
                u=i;
            }
        }
        mark[u]=1;
        sum+=min;
        for(i=0;i<n;i++)
        {
            if(dis[i]>g[u][i])
            {
                dis[i]=g[u][i];
            }
        }
    }
    printf("%d\n",sum);
}
int main()
{
    int T,n,i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&g[i][j]);
                if(i!=j)
                    g[i][j]+=(a[i]+a[j]);
            }
        }
        prim(0,n);
    }
    return 0;
}




zoj QS 1586 Network (prim算法),布布扣,bubuko.com

zoj QS 1586 Network (prim算法)

标签:style   http   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/u011721440/article/details/38706595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!